Elevated request latency and HTTP 429 responses.

Incident Report for Anrok

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 20:05 UTC

Monitoring

A fix has been implemented and we are continuing to monitor.
Posted Mar 10, 2026 - 16:22 UTC

Investigating

A fraction of requests are seeing elevated latency and HTTP 429 responses. We're investigating.
Posted Mar 10, 2026 - 15:46 UTC
This incident affected: Web Application and Billing Integrations and API.