Address resolution issues

Incident Report for Anrok

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 20:10 UTC

Monitoring

We have mitigated the issue and all address resolution operations are succeeding. The system is successfully processing new transactions and working through the backlog of past transactions.
Posted Oct 29, 2025 - 17:47 UTC

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 17:00 UTC

Investigating

Some transactions are currently impacted by a Bing address resolution service outage: https://azure.status.microsoft/en-us/status

You may be experiencing delayed transaction ingestion or failed tax calculations. Anrok is actively investigating and will update this page as we know more.
Posted Oct 29, 2025 - 16:59 UTC
This incident affected: Billing Integrations and API.