Google Cloud Outage

Incident Report for Anrok

Resolved

All Anrok services are fully functional and customers should be able to use their accounts normally as of 3p PT today.
Anrok has completed a comprehensive health check and identified no ongoing service impacts. This outage should be considered resolved and we expect no further updates at this time.
Posted Jun 12, 2025 - 23:36 UTC

Update

Google Cloud services have recovered as of 14:23 PT. https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

All Anrok services are fully functional and customers should be able to use all features at this time. Anrok is actively reviewing transactions from the impacted time period and will update this page at 4p today.
Posted Jun 12, 2025 - 21:36 UTC

Monitoring

Google Cloud services have partially recovered, but Anrok services remain impacted by this outage: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Some Anrok customers may still be experiencing issues loading or using Anrok webpages. We’ll share an update by 3pm PT.
Posted Jun 12, 2025 - 20:41 UTC

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 18:21 UTC

Investigating

Some customers are currently unable to use their Anrok accounts. You may be experiencing errors or pages that do not load. There is an ongoing Google Cloud outage https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW that is currently impacting several Cloud clients, including Anrok. Google is aware of this issue and working to fix it. We’ll share updates as soon as we learn more. We apologize for the inconvenience and will update this status when we know more.
Posted Jun 12, 2025 - 18:21 UTC
This incident affected: Web Application and Billing Integrations and API.